社員名簿/メンバー詳細画面で組織情報履歴が表示されない
2024-10-24 10:58:37 UTC
目次
・事象
・原因
・解決方法
事象
組織情報のマスタの履歴にデータが存在しているのに、そのデータを[個別追加項目グループ一括登録・編集]で登録しても、メンバーの組織情報履歴に反映されない
本記事では、メンバーの主部署履歴が反映されない場合の例として記載します。
事象の詳細
①組織情報の部署マスタ履歴は[適用日時(JST)]2024/10/1〜[営業部]の履歴が登録されている。
②[個別追加項目グループ一括登録・編集]にて田中太郎さんの[営業部]の[更新日時(JST)]を2024/4/1〜に編集してアップロードした。
③しかし、田中太郎さんのメンバー詳細画面で[営業部]2024/4/1〜の履歴が反映されない。
原因
組織情報のマスタの履歴で、[営業部]の適用日時が、田中太郎さんの営業部の更新日時より後の日付になっている
組織情報の部署マスタの履歴で、[営業部]の適用日時(作成日)が2024/10/1からとなっているため、田中太郎さんが実際に[営業部]に所属した2024/4/1時点では[営業部]は存在しない部署として判断され、メンバー詳細には反映されません。
解決方法
組織情報マスタの履歴で[営業部]の[適用日時(JST)]を2023/4/1以前の日付に変更する
営業部のマスタ履歴を、田中太郎さんが営業部に所属した2024/4/1以前の日時に修正することで、メンバー詳細に正しく表示されます。
①[組織情報履歴一括登録・編集]で部署のマスタ履歴をCSVダウンロード。
②ダウンロードしたCSVで[営業部]の[適用日時(JST)]を2024/4/1以前の日時に変更してアップロードする。
変更前
変更後
関連ヘルプページ