ワークフロー/個別追加項目の履歴の削除申請ができない

2026-04-01 05:31:00 UTC

概要

個別追加項目の「過去データの削除申請」をする際に申請画面に[削除]ボタン(添付の赤枠)が表示されない事象について説明します。

 

💡事例の詳細

  • 申請項目に個別追加項目を設定していて「申請範囲の設定」で項目の削除を許可している設定状況
👉️注意事項
前提として[項目の追加のみ許可]の設定にしている場合は
過去のデータ自体表示されないため履歴の削除申請ができません。
履歴の削除申請をするには以下いずれかの設定にする必要があります。
・[項目の更新・削除を許可]
・[項目の追加・更新・削除を許可]
  • 申請者の起票画面に項目の[削除]ボタンが表示されず、削除申請ができない

 

原因

個別追加項目内の全ての項目を申請項目として設定していますか?

該当の中項目内にある全ての小項目が申請項目として設定されていない場合、削除申請ができません。

例)

社員名簿の項目作成状況

・[職務経歴>出張履歴] の中に5つの小項目が作成されている

ワークフローの申請項目の設定状況

・[職務経歴>出張履歴] のうち申請項目として設定されているのが4つの項目のみ

・[職務経歴>出張履歴>スケジュール内容]のみ申請項目に設定されていない状態

 

同じ個別追加項目内で申請項目として設定されていない項目がある場合、[削除]ボタンが非表示となり削除申請ができません。

※申請画面上で見えない項目に対して誤ってデータを削除されないよう、このような仕様にしています。

 

解決方法

中項目内の全ての項目を申請項目として設定してください。

全ての項目を申請項目として設定することで申請画面に[削除]ボタンが表示され、履歴の削除申請が可能です。

削除申請の手順は下記ヘルプページをご参照ください。

ワークフロー/申請方法(メンバー向け)>B.過去データの修正・削除申請をする場合

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています