人事評価/メンバーの組織情報履歴の適用日時を編集すると[メンバーと企業情報の反映]が実行できない

2026-06-04 08:02:46 UTC

目次

・事象
・原因
・解決方法

 

事象

メンバーの組織情報を変更後、[メンバーと企業情報の反映]の確認画面にメンバーが表示されない(もしくは[確認]ボタン自体が表示されない)

 

本記事では、[役職・職位]と[グレード・等級]を変更した場合の例として記載します。

評価期:2024上期
メンバー:営業1課に所属している山田太郎さん

▷2024/7/28までの組織情報
[役職・職位]      :課長
[グレード・等級] :J2

▷2024/7/29以降の組織情報
[役職・職位]      :部長
[グレード・等級] :J1

 

▼2024/7/29時点

山田太郎さんの[役職・職位]を[課長]→[部長]に変更後、[2024上期]評価期に対し[メンバーと企業情報の反映]を実行。

 

▼2024/7/30時点

山田太郎さんの[グレード・等級]を[J2]→[J1]に変更後、評価期への反映を実行せずに組織情報履歴にて[グレード・等級履歴]の適用日時を[2024/7/30]→[2024/7/29]に編集し保存。

その後、[2024上期]評価期に対し[グレード・等級]を[J2]→[J1]に変更するべく、[メンバーと企業情報の反映]画面を開いたところ、[確認]ボタンが表示されず、グレード・等級の変更を反映できない。

 

原因

組織情報履歴の適用日時を[メンバーと企業情報の反映]での[最後の反映時間]より前の日時に編集しているため。

[メンバーと企業情報の反映]では[確認]ボタンがクリックできるかどうかを、[最後の反映時間]とメンバー情報や企業情報の最終更新日時を比較して決定しています。

[最後の反映時間]よりも後に、メンバーの組織情報や企業情報の更新がされている場合は、[確認]ボタンが表示されて変更の反映が可能です。

こちらの事象の場合、[最後の反映時間]が2024/7/29 18:42であるのに対し、[グレード・等級]の適用日時を2024/7/29 0:00に編集しているため、[最後の反映時間]より後に変更されている情報がない、と判断されており、[確認]画面に表示されません。
なお、反映されるメンバーがこのメンバーしかいない場合、[確認]ボタンが表示されないため反映を実行できません。

 

確認画面に表示されない状態で反映を実行した場合

反映対象者が他にいる場合は[確認]ボタンが表示されるため、反映の実行は可能です。
社員名簿の組織情報履歴で「更新日時」を「最後の反映時間」より過去に編集すると、
確認画面の表示と実際の反映内容に差異がでます。
履歴の更新日時を過去日に編集した場合、「メンバーと企業情報の反映」の
確認画面に出ないメンバーでも反映時に最新状態へ更新されます。

 

解決方法

組織情報履歴の適用日時を[最後の反映時間]以降に一時的に編集していただくことで、[メンバーと企業情報の反映]の確認画面に表示されます。

 

①社員名簿の[個別追加項目グループ一括登録・編集]にて山田太郎さんの[組織情報履歴>グレード・等級履歴]の適用日時を2024/7/29 18:42以降〜2024/7/30 0:00(作業時刻)に一時的に編集する。

▷ヘルプページ:社員名簿/組織情報履歴一括登録・編集について>・設定方法:メンバーごとの組織情報履歴の場合

②人事評価側で2024上期に対し[メンバーと企業情報の反映]を実行する。

③社員名簿に戻り、[個別追加項目グループ一括登録・編集]にて山田太郎さんの[組織情報履歴>グレード・等級履歴]の適用日時を2024/7/29付けで再度編集する。

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています